Saturday, March 16, 2013

Jquery Browser Select Dialog Plugin

I have been developing my website, using jquery and in the process have used certain jquery components that are not compatible with IE version less than 9. I started searching for a jquery plugin that shows a dialog when browser is less than IE 9, but could not find one on the internet. I decided to write one highly configurable plugin using which you can show a dialog on website based on your requirements suggesting users new better browser to upgrade to. The plugin is hosted on github and is available under the liberal MIT license at . The plugin can be used to show the dialog not just when it is IE, but when it is IE, Firefox, Chrome, Safari, iCab of the many supported browsers. The dialog can be customized with different backgrounds, different upgrade browser suggestions etc. The github URL has the detailed description of how to use the plugin. To ease users in configuring their desired dialog with the required configuration I have developed the website hosted on github pages here. The same website is present in the example folder in the downloaded zip here along with the real plugin. I plan to include this plugin on all my websites and show dialog to any internet users still on the age old browsers especially IE 8 and below or the users using non-standard browser. One of the main reason of increase in development cost and time is due to the fact that we end up testing and supporting all the major older version of browser which are inherently buggy and non-standard compliant. Hopefully, this plugin will help some number of these users in migrating to newer browsers.

No comments:

Post a Comment